If you are using an older or rare browser, you may run this error in Post Planner:

  • Browser not supported

The Fix

You will need to switch to a browser supported by Post Planner.

Post Planner supports the following browser versions:

  • Chrome 83+
  • Firefox 78+
  • Safari 12.1+
  • Opera 68+
  • Edge 83+

If user is getting the error popup, check if their browser is supported first. It may work with older versions but it is not 100% guaranteed.

Need Additional Help?

Did this answer your question?